Ralink 3572 Wifi Chip Driver modification

Closed - This job posting has been filled and work has been completed.
Web, Mobile & Software Dev Scripts & Utilities Posted 1 year ago

Fixed Price

Delivery by December 20, 2013

$250.00

Budget

Details

I am having inconsistencies with my Ralink 3572 chip when I am using as Hostapd mode.

I have a dev board that is running lubuntu with a Ralink 3572 dongle. I have my laptop connected to the dev board, but when i run ping i get something like this.
The devices are 1 feet away. So theoretically I should be getting ping under 5ms at most.

PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
64 bytes from 10.0.0.2: icmp_req=1 ttl=64 time=116 ms
64 bytes from 10.0.0.2: icmp_req=2 ttl=64 time=141 ms
64 bytes from 10.0.0.2: icmp_req=3 ttl=64 time=144 ms
64 bytes from 10.0.0.2: icmp_req=4 ttl=64 time=465 ms
64 bytes from 10.0.0.2: icmp_req=5 ttl=64 time=86.7 ms
64 bytes from 10.0.0.2: icmp_req=6 ttl=64 time=131 ms
64 bytes from 10.0.0.2: icmp_req=7 ttl=64 time=158 ms
64 bytes from 10.0.0.2: icmp_req=8 ttl=64 time=62.0 ms
64 bytes from 10.0.0.2: icmp_req=9 ttl=64 time=1.85 ms
64 bytes from 10.0.0.2: icmp_req=10 ttl=64 time=117 ms
64 bytes from 10.0.0.2: icmp_req=11 ttl=64 time=129 ms
64 bytes from 10.0.0.2: icmp_req=12 ttl=64 time=141 ms
64 bytes from 10.0.0.2: icmp_req=13 ttl=64 time=91.9 ms
64 bytes from 10.0.0.2: icmp_req=14 ttl=64 time=475 ms
64 bytes from 10.0.0.2: icmp_req=15 ttl=64 time=109 ms
64 bytes from 10.0.0.2: icmp_req=16 ttl=64 time=126 ms
64 bytes from 10.0.0.2: icmp_req=17 ttl=64 time=41.4 ms
64 bytes from 10.0.0.2: icmp_req=18 ttl=64 time=66.5 ms
64 bytes from 10.0.0.2: icmp_req=19 ttl=64 time=12.4 ms
64 bytes from 10.0.0.2: icmp_req=20 ttl=64 time=3.06 ms
64 bytes from 10.0.0.2: icmp_req=21 ttl=64 time=160 ms
64 bytes from 10.0.0.2: icmp_req=22 ttl=64 time=58.8 ms
64 bytes from 10.0.0.2: icmp_req=23 ttl=64 time=87.9 ms
64 bytes from 10.0.0.2: icmp_req=24 ttl=64 time=414 ms
64 bytes from 10.0.0.2: icmp_req=25 ttl=64 time=106 ms
64 bytes from 10.0.0.2: icmp_req=26 ttl=64 time=51.7 ms

I am getting very inconsistent Ping results, i believe there is issue with the RT2X00 driver from Mediatek/Ralink.

The RTL8188CUS chip works very well, but I need it for Ralink 3572

I need someone to look through the RT2X00 and debug this issue.

thanks


About the Client

(5.00) 2 reviews

United States
Grand Rapids 10:49 PM

6 Jobs Posted
34% Hire Rate, 1 Open Job

$294 Total Spent
3 Hires, 0 Active

$38.89/hr Avg Hourly Rate Paid
5 Hours

Member Since Aug 3, 2012